Compdigitec Labs

« | Home | »

Compose key not working with iBus

By admin | December 8, 2012

The iBus input method does not work with the compose key – see Debian bug #591459 and Ubuntu bug #493766. It seems that iBus is intercepting all keystrokes and substituting its own instead, even though xev shows the Multi_key and accent being produced. For example, Multi_Key + ‘ + e leads to ‘e instead of é.

A temporary solution is to export XMODIFIERS=”” to bypass iBus, freeing the keystrokes for compose. However, this disables the iBus input method as it prevents iBus from receiving the keystrokes. XMODIFIERS, however, can be set per application, so one can simply set XMODIFIERS=”” for the specific application that requires the compose key.

If you found this article helpful or interesting, please help Compdigitec spread the word. Don’t forget to subscribe to Compdigitec Labs for more useful and interesting articles!

Topics: Linux | 5 Comments »

5 Responses to “Compose key not working with iBus”

  1. relx Says:
    February 7th, 2022 at 21:21

    … [Trackback]

    […] Read More Information here to that Topic: compdigitec.com/labs/2012/12/08/compose-key-not-working-with-ibus/ […]

  2. dm-blog Says:
    February 24th, 2022 at 07:27

    … [Trackback]

    […] Info to that Topic: compdigitec.com/labs/2012/12/08/compose-key-not-working-with-ibus/ […]

  3. ล่องเรือเจ้าพระยา Says:
    March 24th, 2022 at 20:55

    … [Trackback]

    […] Read More on that Topic: compdigitec.com/labs/2012/12/08/compose-key-not-working-with-ibus/ […]

  4. 누누티비 Says:
    April 5th, 2022 at 16:18

    … [Trackback]

    […] Read More Information here on that Topic: compdigitec.com/labs/2012/12/08/compose-key-not-working-with-ibus/ […]

  5. dumps with pin Says:
    June 24th, 2022 at 00:30

    … [Trackback]

    […] Read More on that Topic: compdigitec.com/labs/2012/12/08/compose-key-not-working-with-ibus/ […]

Comments